#4 Error Mounting USB Drive  

  RSS
trent_land
(@trent_land)
Active Member

Hello, 

 

I came back to a print about halfway through and found the nozzle hovering over the print, with the display screen showing the illustrious red "Error! | #4 Error mounting USB Drive" message. I attempted to restart the print using the same GCode and Prusa-supplied USB, and after pressing "Print," the MINI subsequently crashed and displayed the same #4 error message as before upon reboot. I then attempted this using a different GCode and a different USB (Sandisk) but ended up with the same result. 

 

Has anyone had a similar situation? If so, how did you resolve this? Any tips are appreciated! 

Also, I am currently running FW 4.1.0. 

 

Thanks! Trent       

                       

Link to the crash sequence: prusa-mini-crash-after-print-start_vzkvBInk.compressed                                                                                             

Best Answer by bobcousins:

It appears to crash when you request heater on, so my guess is a faulty heater cartridge. If it draws too much current, the voltage rails collapse and the CPU is reset. You could try disconnecting the heater and see if it does the same.

Posted : 24/07/2020 2:45 am
gordon.w
(@gordon-w)
Estimable Member

There are a significant number of people reporting issues with the USB stick supplied with the printer, but not quite like this!  Looking at the video, I see you insert the stick with the printer powered up. To help with the diagnostics it may be worth trying to insert the USB key before you power up the printer, to try and eliminate that as a cause. I suggest that you talk to Prusa support via chat (on the eshop page) , they may be aware of other people having the same problem.

Posted : 24/07/2020 9:41 am
Oxygen
(@oxygen)
Estimable Member

Use a different USB2 thumb drive and try it again (preferably without your USB extension cable)

Mini with FW:4.2.1 + Bondtech Heatbreak...
Posted : 24/07/2020 10:02 am
crawlerin
(@crawlerin)
Honorable Member

@oxygen

Yeah I'd start with troubleshooting USB - have USB stick checked on a computer and use different stick. Also remove the extension and try without it, if USB stick works directly but not with extension, the extension is bad. My bets are on USB stick being bad.

Posted : 24/07/2020 2:08 pm
trent_land
(@trent_land)
Active Member

@gordon-w, @oxygen, @crawlerin - thanks a ton for your responses! 

 

Unfortunately, I think this might be beyond a USB issue - I was going to move my printer for easier access so I tried to unload the filament, however, it essentially crashed in the same fashion as starting a print did earlier once I hit the "Unload Filament" command. So as a last ditch effort I then tried to reset the printer to factory default settings - it would actually run through the first sequence of the Setup Wizard (test X,Y,Z axis, etc.), however, once it finished testing the Z-axis it once again crashed and went straight back to the initial Setup Wizard screen. 

Videos:

https://forum.prusaprinters.org/wp-content/uploads/2020/07/MINI-Crash-after-Unload-Filament-Command.mp4

https://forum.prusaprinters.org/wp-content/uploads/2020/07/MINI-Crash-After-Z-Axis-Test.mp4

I've emailed them describing the issue so I guess we'll wait and see. @gordon-w you mentioned reaching out via chat, is that Prusa's preferred support method or is just a quicker/more convenient venue for end-users? 

 

Thanks again for your all's feedback - I'll report back on what is (hopefully) found. Trent

 

This post was modified 2 months ago 2 times by trent_land
Posted : 24/07/2020 11:54 pm
gordon.w
(@gordon-w)
Estimable Member

@trent_land

I'm lucky enough not to have needed to contact support myself, but there are many accounts on the forum of email exchanges taking days between replies, but with chat you can have more of a direct conversation, so you should get a much quicker resolution to the issue. 

Posted : 25/07/2020 10:40 am
bobcousins
(@bobcousins)
Reputable Member

It appears to crash when you request heater on, so my guess is a faulty heater cartridge. If it draws too much current, the voltage rails collapse and the CPU is reset. You could try disconnecting the heater and see if it does the same.

Posted : 25/07/2020 11:15 am
trent_land
(@trent_land)
Active Member

@gordon-w

That's awesome - I'm hoping your support-less streak continues :). But I can definitely attest to those previous posts you were mentioning - I received an email response ~36 hours after initially contacting them vs. chat support that responded in ~10 minutes. But you're also spot on with the dialogue, and for that alone I'll definitely be using chat support just to maintain that consistent conversation. 

 

@bobcousins

Good catch - support said the same thing! You're spot on with the heater cartridge being faulty too. Despite it being essentially brand new (installed 5 days prior to this) it had a short in it after testing it with a multimeter per this article from Prusa. After installing a new cartridge, everything was good as new! 

 

Definitely a good learning opportunity and I'm glad it was a simple fix in the end - thanks for your help!

Trent

 

Posted : 01/08/2020 1:55 am
gordon.w
(@gordon-w)
Estimable Member

Pleased you got it fixed!

Posted : 01/08/2020 12:44 pm
Share:

Please Login or Register