mini first layer every print  

Trusted Member

hi, i am pretty sure this has only happened since firmware update but every single print i do now i have to increase the layer height, it was fine at around -350 now i am at -1700 and still having to increase every print to get first layer correct, never had this issue before , anyone else with this problem and managed to rectify it ?

Posted : 08/09/2020 8:12 am
Noble Member

Sounds like your M.I.N.D.A sensor has loosened and needs to be recalibrated.

Posted : 08/09/2020 9:41 am
Trusted Member

That’s the first thing I have checked and it’s tight, I’ve recalibrated over and over with same results , it’s as if it’s forgetting the settings every print ? 

Posted : 08/09/2020 10:07 am
Reputable Member

Make sure your nozzle is nice and tight.

Posted : 08/09/2020 12:17 pm
New Member

I had the same issue and found a thread on the GitHub talking about it. Long story short, adding a heat-up script before first layer calibration solves the issue (for me at least).

Attached is a picture of my first layer with and without the warming up. The difference could not be more striking.

It is interesting since many people say is a probe issue due to lack of temp, but I clearly remember it not happening before the last firmware upgrade. 


This is the GitHub thread:


This post was modified 3 months ago by gios07
Posted : 29/10/2020 3:29 am
Active Member

giordanososa,   keithcowell


This is the 1st 3D printer I've owned personally and I'm having the exact same issues as both of you. Every time I print something I have to lower the nozzle again in 1st layer cal or I'll wind up with a a spaghetti monster print mid-way through the print. This has been a nightmare and I've wasted a good bit of PLA due to the nozzle seemingly raising mid-print during 5+ hour prints near the end. 


It's even more frustrating cause I've been diligent about doing first layer cal before each print and I've done the MINDA probe height check with the thin end of a zip-tie as well as noted its firmness/tightness in its mount by the nozzle. 


Genuinely out of ideas at this point and I'd rather not use 3rd party software. Tired of having 1st layer cal be good one day and the next day produce terrible results without being lowered further. 

Posted : 29/10/2020 12:39 pm
Estimable Member

As giordanososa has said its a known MINDA problem you need to add a custom start gcode in Prusa Slicer. You will find it under printer settings->custom gcode.

My start gcode is below but you can also search the github link provided above to see what others use.


G90 ; use absolute coordinates
M83 ; extruder relative mode
G28 ; home all
G1 Z50 F720 ; park position
M104 S170 ; set extruder temp for bed leveling
M140 S70 ; set bed temp 70C for all filaments
M109 R170 ; wait for bed leveling temp
M190 S70 ; wait for bed temp 70C for consistent leveling heating MINDA
G28 W ; home all without mesh bed level
G1 X100 Y100 F4000
G1 Z1.5 F50
G4 S240 ; wait 4 mins
G28 ; home all without mesh bed level
G29 ; mesh bed leveling
M104 S[first_layer_temperature] ; set extruder temp
M140 S[first_layer_bed_temperature] ; set bed temp
G92 E0.0
G1 Y-2.0 X179 F2400
G1 Z3 F720
M109 S[first_layer_temperature] ; wait for extruder temp
M190 S[first_layer_bed_temperature] ; wait for bed temp

; intro line
G1 X170 F1000
G1 Z0.2 F720
G1 X110.0 E8.0 F900
G1 X40.0 E10.0 F700
G92 E0.0

M221 S95 ; set flow

Original Prusa Mini + Smooth PEI
Prusa Slicer 2.2.0...
Posted : 09/11/2020 10:51 pm
Trusted Member

I agree with @giordanososa and @geoper2. Warmup in custom gcode works for me. 

Posted : 10/11/2020 5:32 am
Trusted Member

From reading many postings in the forums, it seems there is a variability in the temperature sensitivity of the MINDA probe. Some have no issues as it is. Others find that the warmup gcode works. Others get a replacement probe under warranty from Prusa.

For me, the warmup gcode works perfectly. I have not changed my layer height calibration in months.



Posted : 10/11/2020 11:22 am
New Member

Prusa release a new MINDA probe that aims to solve the issue.



Posted : 25/11/2020 11:17 pm
Eminent Member

And the new SuperPINDA indeed solves the issue.

Posted : 24/12/2020 12:14 pm

Please Login or Register