Firmware 4.3.0 RC1 released!  

Page 1 / 2
  RSS
Gordon W
(@gordon-w)
Reputable Member

https://github.com/prusa3d/Prusa-Firmware-Buddy/releases/tag/v4.3.0-RC1

  • QR Error codes
  • Print sheet profiles
  • New fan management
  • Improved selftest and wizard
  • First layer calibration updated
  • Improved filament change process
  • Sound notification changes
  • Improved localization management
  • GUI and WUI (Web User Interface) refactoring
  • Prusa Connect upgraded
  • Bug fixes
Posted : 11/12/2020 8:43 pm
GaetanLE
(@gaetanle)
Active Member

Somehow I won't pass Z-axis test?

Posted : 11/12/2020 10:25 pm
adynis
(@adynis)
Eminent Member

One thing:

I feel that pressing the selection button is different. It seems now it triggers the command on Releasing the button. I don't remember exactly how it was before, but I think I was expecting to have the command triggered onPress, not onRelease ... I have a strange delaying feeling ...

Posted : 12/12/2020 2:59 am
jeffnicol_scotland
(@jeffnicol_scotland)
Eminent Member

So far so good, like the new Z offset for calibration 🙂 Looking forward to testing the bed profiles 🙂 Hoping for wi-fi on the next releases, please Prusa 🙂  

Prusa Mini | BondTech Extruder | BondTech Heatbrake | Supper PINDA
Ender 3 Pro | Micro Swiss Direct Drive and Hotend | WamBam Bed...
Posted : 12/12/2020 1:58 pm
prusanewuser
(@prusanewuser)
Honorable Member

What is good about this "First layer calibration updated"?

Posted : 12/12/2020 3:59 pm
Gordon W
(@gordon-w)
Reputable Member

@prusanewuser

From the release notes: 

"First layer calibration updated (no longer bound to GUI)
Thanks to the GUI and WUI refactoring (see below), the First layer calibration process is no longer bound to GUI. In older versions, the entire calibration logic (movements, waiting, heating) was generated in the GUI, which in turn controlled a Marlin thread through a set of G-codes. Now, the instructions are executed in a Marlin thread directly and the GUI receives notifications about the changes. This will allow the implementation of First layer calibration for different nozzle diameters and to change the calibration object shape in the future.

First layer calibration can be also called using G26 G-Code."

From that I'd say, not a lot right now, but in future releases there will be additional features.

Posted : 12/12/2020 4:27 pm
PGe
 PGe
(@pge)
Active Member

Has anyone else problems connecting to Prusa Connect with this Firmware. I connect to the web browser and see that it works, but no information comes up anymore, just a blank brower and no timeout either, just spinning and spinning

Posted : 12/12/2020 5:00 pm
Mryck
(@mryck)
New Member

@pge

I have the same issue.

Posted : 13/12/2020 5:51 pm
linx
 linx
(@linx)
New Member

Hi 

since i upgraded to 4.3.0 my x axis test fail. When i downgrade4.2.1 again the test run whithout a problem. Is there any iformation how to interpret the created txt files ?

Posted : 14/12/2020 5:06 am
cwbullet
(@cwbullet)
Illustrious Member

QR Error codes are nifty.  

This post was modified 4 months ago by cwbullet
--------------------
Chuck H
3D Printer Review Blog...
Posted : 14/12/2020 10:06 am
Zoltan
(@zoltan)
Moderator
Posted by: @linx

Hi 

since i upgraded to 4.3.0 my x axis test fail. When i downgrade4.2.1 again the test run whithout a problem. Is there any iformation how to interpret the created txt files ?

 What way does it fail? With red x at the end? How about Y axis test? Can you share please the txt file?

This post was modified 4 months ago 2 times by Zoltan
even an old man can learn new things 🙂
Standard I3 mk3s, FW 3.9.3, no closed box, sketchup , fusion 360, PrusaSlicer, Windows 10
PRUSA MINI FW 4.3.1 technical background...
Posted : 14/12/2020 8:14 pm
wdgeek
(@wdgeek)
Eminent Member

@mryck

Also had a similar issue. I first could not connect, and then saw that the static IP address I originally setup was not retained after the update.
After I updated I had to re-establish my "STATIC" ip address that I setup in the text file with my static IP address,

After that was done I was able to connect and I was able to see the limited display for Prusa Connect.
However, If I disconnect Prusa Connect and try to re-establish a connection I just get a blank screen and it never re-connects.
Only way to re-establish a connection is with a reboot of the Mini.
The connection only last one time, and once I exit from Prusa Connect I cannot re-connect.

This post was modified 4 months ago by wdgeek
Posted : 15/12/2020 1:55 am
linx
 linx
(@linx)
New Member

Hi @zoltan

the x axis start to test drive to right side and than it drive to the left and fail when the left side reached. y axis seems to work without an problem. When the z test start the hotend drive into the bed with the x axis carriage which are still on the left side  test_xyz

 

Posted : 15/12/2020 8:58 am
Zoltan
(@zoltan)
Moderator

@linx

thanks a lot,

The others, can you please also share? 

We will analyze them.

Zoltan

even an old man can learn new things 🙂
Standard I3 mk3s, FW 3.9.3, no closed box, sketchup , fusion 360, PrusaSlicer, Windows 10
PRUSA MINI FW 4.3.1 technical background...
Posted : 15/12/2020 1:09 pm
Nallie
(@nallie)
New Member

I have installed it on my Prusa mini and the only thing that I noticed is that Prusa connect is working via Safari on IOS but not on MacOS.

And it is a disapointment that it’s still not possible to sent the print directly to the printer without the use off usb-stick or Octoprint solution.

 

Posted : 15/12/2020 4:43 pm
Zoltan
(@zoltan)
Moderator
Posted by: @pge

Has anyone else problems connecting to Prusa Connect with this Firmware. I connect to the web browser and see that it works, but no information comes up anymore, just a blank brower and no timeout either, just spinning and spinning

Guys,

can you share which browser and under which OS do you use it?

even an old man can learn new things 🙂
Standard I3 mk3s, FW 3.9.3, no closed box, sketchup , fusion 360, PrusaSlicer, Windows 10
PRUSA MINI FW 4.3.1 technical background...
Posted : 17/12/2020 9:28 am
wdgeek
(@wdgeek)
Eminent Member
Posted by: @zoltan
Posted by: @pge

Has anyone else problems connecting to Prusa Connect with this Firmware. I connect to the web browser and see that it works, but no information comes up anymore, just a blank brower and no timeout either, just spinning and spinning

Guys,

can you share which browser and under which OS do you use it?

I'm using Windows 10,  Microsoft Edge Browser. (all current versions) Also don't know if it matters but I have an Eero Wireless Router that handles the wifi and a TP-Link switch that handles the wired internet connections.

This post was modified 4 months ago by wdgeek
Posted : 18/12/2020 7:57 pm
Lupin
(@lupin)
Trusted Member

For me the prusa connect works, it just shows empty temperature/time chart when the printer is switched on. It loads bit sluggishly, but quick enough. Im using Ubuntu 20.04 and Browser is Firefox.

Mini is connected via cable to my router, and it gets almost static IP address even though it uses dhcp currently (haven't bothered with static lan settings). I can conenct to mini with browser similarly regardless of my laptops connection (cable, wifi, endpoint, router). So far works well.

The firts layer calibration has slight changed the direction, now it starts immediately to draw those lines after it has rushed plastic out of the nozzle to the front edge of the sheet. After it has finished with the same small rectangle in the back of the sheet, it will stop. It is now easier to examine how it went and you can remove the sheet without moving any of the axes.

Posted : 18/12/2020 8:11 pm
Lupin
(@lupin)
Trusted Member

The new sheet profile is great. I have now both, smooth and textured calibrated and just after I had second one calibrated I switched to the first one (textured) started print and when it was getting ready, went to "live Z adjust" and saw that the basic setting was what I had originally calibrated for it. I stopped print, switched  smooth sheet, selected smooth1 from setting ans again started print. And again when the printing was about to start, I went to live Z -adjustment and saw that the base was exactly what I had gotten for it in calibration.

Contrary to what I thought, the Prusa Connect does not show which sheet I have selected even though I now have two of them calibrated. I think I will report this as a feature request, but I read the release notes again, just to be sure before I use the B-word.

Anyway, so far it has worked well. I just haven't printed anything properly with the new firmware. I guess I set up the new slicer as well and search for some useless figurine to print.

How does the sheet profile work for you?

Posted : 18/12/2020 8:48 pm
Lupin
(@lupin)
Trusted Member

Prusa connect works well with phone (Sailfish OS, browser is something mozilla based). It loaded up immediately via phone. I guess it was sluggish the first time or because the printer was still somewhat busy after being switched on.

Posted : 18/12/2020 8:56 pm
Page 1 / 2
Share:

Please Login or Register