4.2.1 Firmware for Original Prusa MINI  

  RSS
Jakub Dolezal
(@jakub-dolezal-2)
Admin

This is a bug fix release recommended to all Original Prusa MINI owners.

Summary

  • Random BSOD fixed

Random BSOD fixed

Some users have reported an issue with a random blue screen of death (BSOD), causing the printer to halt. The problem was with synchronization of the inter-task messages from a message queue, which were occasionally incorrectly processed. Most of the reported BSODs occurred in the webServerTask responsible for running the web user interface. However, it was later found out it wasn't the fault of the webServerTask itself, the same error could have happened with other services as well, even regardless of the printer being connected to the Ethernet (LAN network).

There are several firmware versions, which can be possibly affected (4.0.5, 4.1.0 and 4.2.0) and it is recommended to update them to this latest release 4.2.1.

Side-note: The developers started to work on it as soon as this BSOD issue was reported. However, finding and reproducing this error was very complicated and took almost an entire week as most of the company's printers were unaffected even after several days of non-stop printing.

Supported printer:

  • Original Prusa MINI

Download link:

https://www.prusa3d.com/drivers/

How to flash the firmware on MINI:

  1. Copy the firmware file (.bbf) onto the USB drive with FAT32 formatting
  2. Insert the flash drive in the MINI's USB port
  3. Turn the printer ON (or reset it)
  4. A new screen will appear
  5. Confirm you want to flash the firmware
  6. Wait till the firmware is flashed and printer fully boots into the home screen

Please report any bug here:

github.com/prusa3d/Prusa-Firmware-Buddy/issues

As always, we wish you happy printing and look forward to your feedback!

This topic was modified 5 months ago by Jakub Dolezal
Assembly manuals / Knowledge Base
The guy behind Prusa assembly manuals......
Posted : 01/09/2020 9:08 am
enganear
(@enganear)
Eminent Member

I hope this fixes the post print behavior that some have experienced, including me. FW released after 4.05 so far continues to move the axes after the head has parked even though there is no gcode to make these moves. This has been detailed in another thread, but no mention of a solution yet.

Posted : 02/09/2020 11:55 pm
kevman
(@kevman)
Estimable Member

just upgraded to this firmware from 4.05. the self test fails when it does the temperature check at 108-110 degrees. Have not tried any prints yet.

Posted : 12/12/2020 4:19 pm
Share:

Please Login or Register