Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche
 
Notifications
Clear all

Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche  

  RSS
BBen
 BBen
(@bben)
Active Member
Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche

Hallo, ich habe hier ein einsy 1.1a, welches einen seltsamen Defekt aufweist.

Nur die Z-Achse läßt sich bewegen .. Bootloader und aktuelle Firmware sind drauf. Das Board lief noch nie, daher vermute ich einen generellen Defekt. Gibt es einen zusammenhang zwischen den X,Z und Extruder Achsen auf dem Board, oder muss ich Zeit in Ausmessen investieren. Vielleicht gibts da schon Erfahrungen mit dem Layout.

 

viele Grüße

Ben

Posted : 19/11/2020 9:51 pm
Holger
(@holger-2)
Honorable Member
RE: Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche

@bben

Hallo Ben,

das Einsy Board funktioniert bei mir recht zuverlässig, bisher bei 3 Druckern keine Ausfälle. Das gilt wohl auch für fast alle anderen Anwender. Für jede Achse gibt es einen eigenen Treiber (TMC2130). Das 3 von 4 Achsen nicht funktionieren ist sehr unwahrscheinlich aber natürlich nicht unmöglich. Schau Dir die Stecker von den Motoren an, sind die Leitungen richtig eingesteckt und sind die 4 Motor-Leitungen am Stecker korrekt im Stecker eingesetzt? Jeder Motor enthält 2 Phasen (4 Leiungen), wenn die Leitungen vertauscht sind ist vieles möglich, Motor dreht falsch herum oder es dreht sich gar nichts.
Wenn Du den Drucker als Kit oder fertig montiert von Prusa bezogen hast, solltest Du Dich an den Prusa-Support per Chat wenden.

Grüße, Holger 🙂 

2x Personal MK3IR-BMG09 (Full) BEAR + MMU2S mod., ......
Posted : 20/11/2020 7:35 am
Holger
(@holger-2)
Honorable Member
RE: Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche

ps. Wenn die Z-Achse funktioniert, wie Du schreibst, kannst Du zur Prüfung der anderen Stepper-Motoren (X, Y, E) diese vorübergehend an einen Anschluss vom Z-Motor anstecken, dann sollte sich der entsprechende Stepper-Motor drehen, wenn die Z-Achse bewegt wird. Aber bitte dazu beide Z-Motoren abstecken. Die Z-Motoren haben einen anderen Innenwiderstand als die X, Y & E Stepper und können deshalb parallel betrieben werden. Die Belegung der Stecker ist für alle Motoren gleich.

Viel Erfolg, Holger 🙂 

2x Personal MK3IR-BMG09 (Full) BEAR + MMU2S mod., ......
Posted : 20/11/2020 8:04 am
Holger
(@holger-2)
Honorable Member
RE: Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche

ps. und noch ein kleiner Tipp: die Stepper-Motoren sollten möglichst nie oder wenn, dann nur sehr, sehr langsam manuell bewegt werden. Bei manueller Bewegung arbeiten die Stepper-Motoren als Generator und können dabei die Motor-Treiber auf den Einsy-Board zerstören.

Grüße, Holger 🙂 

2x Personal MK3IR-BMG09 (Full) BEAR + MMU2S mod., ......
Posted : 20/11/2020 8:16 am
BBen
 BBen
(@bben)
Active Member
Topic starter answered:
RE: Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche

HI,

danke für die schnellen Antworten. Das mit den Motoren habe ich schon getestet. Ich kann mit Sicherheit sagen, dass es am Board liegt. Meine Frage bezog sich aufs das BoardLayout, ob evtl.  eine gemeinsame Versorgungsleitung zu X,Y,E gehen und eine getrennt zu Z, was dann erklären würde, warum es nicht funktioniert.

Es wurde neu verbaut, verkabelt und dann getestet. Manuell wurde nichts bewegt .. mir fiel es auf, da der Selftest der Achsen fehlschlug.
Ich vermute, dass es einen Grund geben muss, warum komischerweise die beiden Z noch funktionieren, die anderen aber nicht. Sonst funktioniert das Board.
Es hat nie gedruckt und wurde grade erst neu verbaut - vielleicht liegt ein Produktionsfehler vor. Das Board war aus einer Ersatzteilkiste und noch verschweißt.

Posted : 20/11/2020 11:26 am
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche

@bben

Wenn Dir mit diesem Layout vielleicht geholfen ist:

Schematic Prints_Einsy Rambo_1.1a

Wenn Du sicher bist, dass das Einsy defekt ist (ist eigentlich ein extrem robustes board), würde ich mich umgehend an den Prusachat wenden. Einfach einloggen und den eshop selektieren. Einige Sekunden später sollte rechts unten das Chatfenster erscheinen. Tut es das nicht, hast Du wahrscheinlich einen Adblocker oder Ähnliches installiert.

 
Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 20/11/2020 1:10 pm
BBen
 BBen
(@bben)
Active Member
Topic starter answered:
RE: Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche

@karl-herbert

Hi, das Schema kenne ich, es ist leider nur der Schaltplan, nicht aber das Platinenrouting.  Im Routing können zusammenhängende Signale durchaus so angelegt sein, dass eine Unterbrechung zu einem solche selektiven Fehler führen kann. Ich werde das Board dann wohl mal ausmessen müssen.

Der Prusa-Suport kann mir da nicht helfen, außer dass ich ein neues kaufen müßte 😉 Besagtes Board habe ich ja nicht aus dem PrusaShop gekauft und ich weiß nicht mal, ob es der Vorgänger auch von dort bezogen hat.

vielen Dank und Grüße
Ben

Zur Robustheit: naja .. ich habe schon zwei defekte Einsy Board hinter mir ... eines hat einen W25C20CL Error (wurde auf Garantie von Prusa ersetzt - Danke dafür). Das Andere liest plötzlich keine SD-Karten mehr und startet bei abgeklemmter MMU nicht mehr. Die Fehler waren einfach nach einen Druck da ... es wurde nichts geändert. Die Boards wurden ersetzt und alles funktioniert ... nun habe ich aber mit dem besagten Board hier Probleme

This post was modified 1 year ago by BBen
Posted : 20/11/2020 3:03 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche

@bben

"Das Andere liest plötzlich keine SD-Karten mehr und startet bei abgeklemmter MMU nicht mehr. Die Fehler waren einfach nach einen Druck da ... es wurde nichts geändert. Die Boards wurden ersetzt und alles funktioniert ... nun habe ich aber mit dem besagten Board hier Probleme"

SD-Karten Leseprobleme könnten auch in Zusammenhang mit der LCD Platine stehen. da wird relativ oft über Probleme (Wackelkontakte) berichtet. Bzgl. der abgeklemmten MMU2 denke ich, müsste man wissen was abgeklemmt wurde. Wenn ich die MMU2 deaktiviere trenne ich nur die Datenleitungen worauf hin diese vom MK3 nicht mehr erkannt wird (N/A), alles andere bleibt unberührt.

W25C20CL error steht in Zusammenhang mit dem SPI Flashchip. Ich denke Du verwendest noch ein älteres board oder einen Fremdhersteller. Factory reset und Installation der nur englischen Menüführung könnte helfen.

Mein MK3 druckt schon seit 3 Jahren (gefühlte eine Million Stunden) in einem geschlossenen Gehäuse bei Temp. bis zu 50Grad C. und es ist eines der wenigen Elemente, welches bislang standgehalten hat.

Aber wie überall gibt's auch hier natürlich Unterschiede in der qualitativen Ausführung.

 
 
Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 20/11/2020 3:40 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Einsy Board defekt - nur Z-Achse funktioniert. ...Fehlersuche

Was mir gerade noch einfiel - Vielleicht findest Du hier, falls nocht nicht bekannt, hilfreiche Infos: https://github.com/ultimachine/Einsy-Rambo

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 20/11/2020 3:49 pm
i4004
(@i4004)
New Member
ESD Problem

hatte und hab ein ähnlichs problem, dass tmc overheat auf dem lcd angezeigt wurde. hab es prusa gemeldet, der drucker ist erst 3 monate alt. leider dauert es zur zeit sehr lange, bis man eine antwort bekommt.

es passierte folgendes, zuerst lief auf einmal die mmu nicht mehr und ich musste die y und z achsen von hand bewegen. hab dann die mmu abgehängt und der drucker lief wieder. 1 woche später mitten im druck kam der tmc fehler. durch die lange wartezeit habe ich das board selbst angeschaut, da wir elektronische steuerungen entwickeln. wir messten zuerst die relevanten wiederstände des tmc130 baustein aus und schlossen danach ein netzteil an. es zeigte sich schnell dass der u6 chip heiss wurde ohne last.
Ein überspannungs defekt tritt erst nach 2-14 wochen auf, wie bei einem blitzeinschlag. wir vermuteten das schon vorher, da wenn die achsen bewegt werden der lcd aufleuchtet. als ursache ist unser meinung nach das bewegen der achsen von hand.
sobald wir ein neus board erhalten werden wir bei jeder achse 6 znr varistoren und 4 schottky dioden anbringen wie im datenblatt vom tmc2130 beschrieben. schade dass solche mängel nicht längst mit einem neuen release behoben werden, zumal dies bei vielen prusa benutzern passiert, dass durch diese überspannung ein chip zerstört wird. die teile kosten zusammen in stückzahlen (mouser elektronik) um 46 cent für ein board.

Posted : 28/09/2021 3:43 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: ESD Problem

Das Problem wurde einige male diskutiert, ist deshalb nicht neu. Deshalb war/bin ich immer sehr vorsichtig beim manuellen Bewegen der Achsen und "entlade " meine Person immer vor dem Handlung mit dem Drucker. Falls Du aber eine Lösung dazu parat hättest, wäre eine Veröffentlichung sehr interessant, da dies der eine oder andere User gerne inkludieren würde.

Danke!

Schöne Grüße,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen....
Posted : 28/09/2021 4:46 pm
i4004
(@i4004)
New Member
RE: ESD Problem

Ab und zu findet man was. bin nur erstaunt, dass dieses problem nie behoben wurde. weiter ist bei der prusa nichts geerdet, da kann sich schnell eine statische ladung hochschwingen. werde die plastikteile noch mit einem leitenden lach besprayen nach vorbehandlung mit einem primer.
Die Schaltung findest du im datenblatt vom tmc2130. die smd varistoren lassen sich gut einlöten beim stecker. habe 25.5v typen bestellt und die angegeben schottky dioden.

warte jetzt mehr als 6 wochen, damit der drucker wieder läuft. der support von prusa reagiert sehr spät, respektive dauert es sehr lange bis eine antwort kommt, was für mich kein gutes zeichen ist, da sich leicht erahnen lässt, dass die überlastet sind. nie wieder prusa. haben 4 andere drucker (marken) im einsatz wo ununterbrochen laufen. nur der prusa konnte bis jetzt noch nicht produktiv eingesetzt werden. haben  inzwischen einen weiteren anderen bestellt um den ausfall auszugleichen. ich arbrbeite in einem forschungs und entwicklungslabor wo wir eloktronische apparate entwickeln wo nachher in die grossproduktion gehen. dabei achten wir auch stets dass wir möglichst wenige frühausfälle und die geräte esd mässig sicher sind, dabei haben wir 2 geräte von schaffner um statische entladungen zu simulieren sowie netzspikes.

Posted : 28/09/2021 5:08 pm
Share: